Business Phone Systems

Previous Thread
Next Thread
Print Thread
Rate Thread
Joined: Mar 2007
Posts: 49
Member
OP Offline
Member
Joined: Mar 2007
Posts: 49
I just set up a used DK16 with several digital phones and a couple standard telephone devices. The base KSU has a KSTU and K4RCU for the standard phones. Several of the phones have HHEU's installed for headsets. I have run programs 90, 92 and 03 (accepting all the defaults for 03 slots and codes) and set date, time and day.

There are two problems.

(1) I did not think to check if all the phones do this while I was out at the building, but with at least a couple of the phones, it seems that the handsets do not work. Calling from one CO number to another assigned to us, the station where I tried to answer only had speakerphone, and likewise at the calling station. Not only was the speakerphone the default device, but I couldn't seem to transfer to the handset.

Does having an installed HHEU affect this behavior even when there is no headset attached?

A couple posts here gave me the idea that either Program 10-1 (Tone First/Voice First) or a bad hookswitch might be involved.

(2) Both standard phone devices have no dial tone. Is this a programming issue?

Atcom VoIP Demo
VoIP Demo
Joined: Feb 2005
Posts: 1,037
Member
Offline
Member
Joined: Feb 2005
Posts: 1,037
Welcome to the Board! welcome

1) I'd say you may have bad hook switches on the phones.
2) Run program 32 for your preference of off-hook dialtone.

After running your programs did you reset the system?

Have you checked your battery strap?

Is there an expansion cabinet attached?

Are you sure of your pinouts of station ports?

Which pairs are you using for the standard telephones?

Joined: Jan 2006
Posts: 2,266
Likes: 1
Member
*****
Offline
Member
*****
Joined: Jan 2006
Posts: 2,266
Likes: 1
program 32 will have no effect on the standard phones. standard phones get intercom dial tone, 32 doesn't apply to standard.

after running 03 did you cycle the power?

Joined: Mar 2001
Posts: 581
Member
Offline
Member
Joined: Mar 2001
Posts: 581
John
After you reset take good phone to all digital stations and test. That will eliminate the bad hookswitch variable. As tbob said be sure you are on the correct pins for your standard ports.
m

Joined: Mar 2007
Posts: 49
Member
OP Offline
Member
Joined: Mar 2007
Posts: 49
Thanks for all of your initial replies!

I was back out at the building later and found out that some of the desksets were good and some had the no-handset speaker-only problem. So I've finished soldering in new hookswitches and will see what we have today with the digital sets.

As for the standard stations problem: I'll check the pinouts of the standard ports while I'm there -- that would be a nice simple fix!!

Other points:
- Yes, I cycled power after running the initial programs.
- Yes, I checked the battery strap with the initial going-over.
- No, no expansion cabinet involved.

Joined: Mar 2007
Posts: 49
Member
OP Offline
Member
Joined: Mar 2007
Posts: 49
Thanks to Steve and Martin, and especially to Toshiba Bob for being the first to cite the likeliest causes. Replacing the hookswitches took care of the non-functioning handset problem. And a voltmeter at the MDF confirmed that I'd inherited a setup where the standard phone ports are not wired right. Should be a straightforward fix.

I do have one more problem though, which I will also post to a new thread: In my first tests of the 5 phones, I had one phone that didn't ring. After replacing the hookswitches on all 5, I now have (4) 10-button phones that don't ring, and (1) 20-button phone that does. Apart from replacing the hookswitches, the only other thing I can note is that though the KSU has been plugged in the whole time, the power supply has been switched off for 11 days. Can anyone guess what's going on with this?


Moderated by  Carlos#1, phonemeister 

Link Copied to Clipboard
Forum Statistics
Forums84
Topics93,745
Posts636,435
Members49,622
Most Online5,661
May 23rd, 2018
Popular Topics(Views)
Today's Birthdays
cTopher, djmoutt, ffej010, Kenneth J McLean, telephonegunner, Tellink
Newest Members
noriod45, Levi1337, jackbeelerDCS, blentz, RockyTop
49,622 Registered Users
Top Posters(30 Days)
blentz 6
Toner 5
jsaad 5
dans 4
Who's Online Now
2 members (SamF, nortelvoip), 26 guests, and 16 robots.
Key: Admin, Global Mod, Mod
Contact Us | Sponsored by Atcom: Business Phone Systems | Terms of Service

Sundance Communications is not affiliated with any of the above manufacturers.
©Copyright Sundance Communications 1998-2022
Powered by UBB.threads™ PHP Forum Software 7.7.5