Business Phone Systems

Previous Thread
Next Thread
Print Thread
Rate Thread
#604673 10/11/16 05:01 AM
Joined: Feb 2012
Posts: 99
Member
OP Offline
Member
Joined: Feb 2012
Posts: 99
I'm using a WE 620A2 Panel connected to a 79B5 power plant. I can't find the maximum number of lamps that a 400 series KTU can support, I'm guessing between 15 and 20 (all cable runs < 30 ft). I also found a BSP reference to a 469 Lamp Extender KTU that also plugs into the 620 panel, providing 20 lamps per ckt. Of course, I can't find any on eBay! Closest is a Melco KT-631 Lamp Extender. Anyone have any advise on either? Regards, Jim

Last edited by [email protected]; 10/11/16 05:24 AM.
Atcom VoIP Demo
VoIP Demo
Joined: May 2007
Posts: 5,049
Likes: 3
Moderator-1A2, Cabling
*****
Offline
Moderator-1A2, Cabling
*****
Joined: May 2007
Posts: 5,049
Likes: 3
You've got more then 20 sets with the same line appearance and all cable runs are less then 30'!

Are the sets stacked one on top of each other?

The Melco Lamp Extender was - as I recall - a very good product.

Sam

PS. Perhaps this should be moved to 1A2?


"Where are we going and why are we in this hand basket?"
Joined: Feb 2012
Posts: 99
Member
OP Offline
Member
Joined: Feb 2012
Posts: 99
Sam, Actually all the various 1A2 sets from my collections are on display on library bookshelves! How else could I use all that great equipment?

Joined: Sep 2006
Posts: 3,290
Member
*****
Offline
Member
*****
Joined: Sep 2006
Posts: 3,290
The 51A lamp draws about 40 mils. So 50 of them draw 2 amps, which is the usual fusing for a 1A2 system. Maybe this helps?


Arthur P. Bloom
"30 years of faithful service...15 years on hold"

Joined: Feb 2012
Posts: 99
Member
OP Offline
Member
Joined: Feb 2012
Posts: 99
Arthur, That makes the most sense! Any idea how rare the 469 Lamp Extender KTU is? Haven't see any on eBay, mostly 400 series KTUs.

Joined: Oct 2004
Posts: 375
Member
Offline
Member
Joined: Oct 2004
Posts: 375
We use to use a Dracon Lamp Extender on 10A2. It was contained on a small 66 Block. Here is the link but I cant seem to get it to post properly.



https://www.flickr.com/photos/[email protected]/4257610614


Joined: Oct 2004
Posts: 375
Member
Offline
Member
Joined: Oct 2004
Posts: 375


Moderated by  ChrisRR, EV607797, Silversam 

Link Copied to Clipboard
Forum Statistics
Forums84
Topics93,827
Posts636,768
Members49,645
Most Online5,661
May 23rd, 2018
Popular Topics(Views)
Today's Birthdays
Dan Powell, EKPTECH86, History, LinuxTech, Mike Miller, ttcfcl
Newest Members
KoolBreeze, PhoneGuy827, julesm, Helen.D, AlAl
49,644 Registered Users
Top Posters(30 Days)
ramo 12
pvj 11
Toner 9
Who's Online Now
1 members (nameless), 17 guests, and 18 robots.
Key: Admin, Global Mod, Mod
Contact Us | Sponsored by Atcom: Business Phone Systems | Terms of Service

Sundance Communications is not affiliated with any of the above manufacturers.
©Copyright Sundance Communications 1998-2023
Powered by UBB.threads™ PHP Forum Software 7.7.5