Phone Systems

Previous Thread
Next Thread
Print Thread
Rate Thread
Modem issue
#637166 06/18/20 03:51 AM
Joined: Jan 2005
Posts: 15,204
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
OP Offline
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
Joined: Jan 2005
Posts: 15,204
Since most modems use commands comparable to the Hayes "AT" set, I'm scratching my head on this issue I'm having. I have a USB modem 'dongle' that works on a hit-or-miss basis. It used to work flawlessly. I began noticing that many of the integrated modems in systems that I dial into have stopped connecting. Once I started audible monitoring, In noticed that the modems on the far end have started answering in fax mode (an experienced modem user can tell by the sound). I put two and two together and determined that the ones called by this dongle modem are the ones that mysteriously start answering as a fax. The only solution is to reboot the distant systems, requiring a dreaded site visit; the exact reason why we have these modems in the first place.

Another modem I use in my desktop PC has worked flawlessly for years and years. It rarely lets me down, despite the fact that it's hard to get a real phone line any more. Somehow, some way, it always manages to negotiate a connection.

So here's my question. It is obvious that this dongle modem is sending some kind of reversal command to the distant modems to make them start doing this. Again, through the process of elimination, this ONLY happens when I call an otherwise perfectly-functioning modem from the USB modem. What I need to know is what AT command can I send to this dongle modem to disable its fax capabilities and more importantly, how to stop it from sending commands out to the others. I've scoured the lists of AT commands, but the way those things are written isn't very clear to me as to which one is causing the problem. I'd love to disable the fax functionality on this thing entirely, if that's possible.

The terminal software that I am using doesn't seem to send the desired initialization string of commands that I'd like. That's OK, I don't mind just entering the ones that are important each time I use it. I just need to know which command is the culprit for turning my large systems that are hundreds of miles away into fax machines. AT&F and ATZ aren't helping. Any ideas?


Ed Vaughn, MBSWWYPBX
Telephone Equipment Search
Re: Modem issue
EV607797 #637167 06/18/20 04:51 AM
Joined: Jun 2006
Posts: 2,787
Moderator-Samsung
*****
Offline
Moderator-Samsung
*****
Joined: Jun 2006
Posts: 2,787
The remote modem thinks you are a fax. It's receiving a tone from your modem telling it it's a fax.
Atz just resets the modem to its default init string.
Atz2 will tell it to use default unit steering 2 iirc.

It's likely a atsx=y command, what it is though I can't say. Apex using dial-up years ago.
Though it's all used in security, but the phone line issue is a problem.
Voip lines aren't real good at modem transmission.
You could try changing the baud rate maybe

Edit
https://m2msupport.net/m2msupport/general-at-commands/

Try that. It mentions how-to query for fax mode and enable/disable it

Last edited by nameless; 06/18/20 04:56 AM. Reason: Spelling and more information
Re: Modem issue
EV607797 #637181 06/19/20 02:46 AM
Joined: Jan 2005
Posts: 15,204
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
OP Offline
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
Joined: Jan 2005
Posts: 15,204
S-Registers are just timers, so I seriously doubt that one of those is causing this. I'm sure there is a & or % command that disables the fax function on my end. That's the problem: I don't know which one it is and the documentation on many of the AT commands are clear as mud!

The link you provided is a little bit more descriptive than what I've been reviewing. It would appear that the device mode being set to zero would be what I'm looking for. Now, to figure out the actual AT command line for it!

Many of these locations aren't using IP lines, and I've tried steering the baud rate down to no avail.


Ed Vaughn, MBSWWYPBX
Re: Modem issue
EV607797 #637186 06/20/20 01:21 AM
Joined: Jun 2006
Posts: 2,787
Moderator-Samsung
*****
Offline
Moderator-Samsung
*****
Joined: Jun 2006
Posts: 2,787
They way I read it

At+fclass? Should tell you what it's set to

At+fclass=0 should set it to data mode only

Re: Modem issue
EV607797 #637195 06/21/20 06:57 PM
Joined: May 2002
Posts: 3,930
Moderator-Avaya, Polycom
*****
Online Content
Moderator-Avaya, Polycom
*****
Joined: May 2002
Posts: 3,930
Ed

I have 2 statements.

1. This is way above my pay grade
And
2. It's scary when Ed has to ask a QUESTION

Re: Modem issue
hitechcomm #637199 06/22/20 12:34 AM
Joined: Dec 2005
Posts: 8,577
Spam Hunter
*****
Online Content
Spam Hunter
*****
Joined: Dec 2005
Posts: 8,577
Originally Posted by hitechcomm
Ed

I have 2 statements.

1. This is way above my pay grade
And
2. It's scary when Ed has to ask a QUESTION

laugh


I Love FEATURE 00

www.dexman.webs.com
Re: Modem issue
nameless #637200 06/22/20 03:17 AM
Joined: Jan 2005
Posts: 15,204
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
OP Offline
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
Joined: Jan 2005
Posts: 15,204
Well, thanks for the compliment, Ken, but it's legit. I don't come here often seeking answers, in fact I'd much rather provide them. This time, I'm stumped!


Ed Vaughn, MBSWWYPBX
Re: Modem issue
nameless #637201 06/22/20 03:19 AM
Joined: Jan 2005
Posts: 15,204
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
OP Offline
Moderator-Vertical, Vodavi, 1A2, Outside Wire
*****
Joined: Jan 2005
Posts: 15,204
Originally Posted by nameless
They way I read it

At+fclass? Should tell you what it's set to

At+fclass=0 should set it to data mode only

Well, after much optimism, I did a query and unfortunately, AT+FClass? results in 0. Back to the drawing board.


Ed Vaughn, MBSWWYPBX

Moderated by  MooreTel, tito1411 

Link Copied to Clipboard
Forum Search
Most Recent 5 Post
OAS MGI failure on OS7200S
by btil - 07/15/20 10:56 PM
T1 circuit question for T1 experts
by jsaad - 07/15/20 03:04 PM
NEC SL1100 24 button DESI labels???
by maxcomm - 07/14/20 08:47 PM
2100 questions
by conxtel - 07/14/20 08:37 PM
Samsung Pro Star DCS
by bditech - 07/14/20 02:34 PM
Who's Online Now
35 members (justbill, Village of Fonda, Keyset6, Bob3470, nonameyet, C5Z, Yoda, Mercenary Roadie, Curlycord, Arthur P. Bloom, JBean3329, btil, Carl Navarro, metelcom, tim10, dans, teleco, Biztel Cuban Okie Tech, BobRobert, hitechcomm, Ruben, jsaad, Professor Shadow, OBT, gelehu, Touch Tone Tommy, hbiss, ECI Tech, conxtel, dexman, KRRath, pvj, Rok1215, inspector754, tellithigh), 562 guests, and 49 robots.
Key: Admin, Global Mod, Mod
Popular Topics (Views)
Forum Statistics
Forums94
Topics93,816
Posts636,385
Members49,313
Most Online5,661
May 23rd, 2018
Today's Birthdays
agvcrc, IAMME1, nundance
Newest Members
tellithigh, HMHRIT, StevCom, DaleG, jlspeck
49312 Registered Users
Get Tech Support Now! Click the banner below
Get Tech Support Now!
EMP & Lightning Home Surge Protection
EMP - Click Here!
Top Posters (30 Days)
dexman 25
dans 12
pvj 7
Bluewater Sailing
https://www.patreon.com/bePatron?u=5256033
EMP Shield for Commercial - Home & Vehicle
Use Coupon code SAVE - Click Here!
Servpro Ventura 24-Hour Emergency Service
Free Estimates call us now 24Hours
Contact Us | Telephone System Tech Support | Terms of Service

Sundance Communications is not affiliated with any of the above manufacturers.
©Copyright Sundance Communications 1998-2020
Trusted Partners