Ok I guess a few of you were having difficulty getting started with my lab. I have put a very simple config on the devices and configured basic dynamic routing. I am posting the configs as a baseline so please change them and play around with them, but here they are.

R1#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
enable password cisco
!
!
!
!
!
network-clock base-rate 56k
ip subnet-zero
!
!
!
controller T1 1
!
!
process-max-time 200
!
interface Ethernet0
ip address 172.16.1.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 172.16.255.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Switch0
no ip address
no ip directed-broadcast
encapsulation frame-relay
no fair-queue
!
router eigrp 100
network 172.16.0.0
no auto-summary
!
no ip http server
ip classless
!
!
line con 0
password cisco
transport input none
line aux 0
line 2 3
line vty 0 4
password cisco
login
!
!
!
end

R2#sh run
Building configuration...

Current configuration : 814 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
enable password cisco
!
!
!
!
!
network-clock base-rate 56k
ip subnet-zero
!
!
controller T1 0
!
controller T1 1
!
!
!
!
interface Ethernet0
ip address 172.16.2.2 255.255.255.0
!
interface Serial0
ip address 172.16.255.2 255.255.255.252
no fair-queue
clockrate 64000
!
interface Serial1
ip address 172.16.255.6 255.255.255.252
clockrate 64000
!
interface Switch0
no ip address
encapsulation frame-relay
no fair-queue
!
router eigrp 100
network 172.16.0.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
!
!
!
line con 0
password cisco
login
line aux 0
line 2 3
line vty 0 4
password cisco
login
!
!
!
end


R3#sh run
Building configuration...

Current configuration : 565 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
ip address 172.16.1.2 255.255.255.0
!
interface Ethernet1
ip address 172.16.2.1 255.255.255.0
!
interface Serial0
ip address 172.16.255.5 255.255.255.252
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router eigrp 100
network 172.16.0.0
no auto-summary
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end


It also seems people were having difficulty navigating the rotary reverse telnet groups. Here is another direct access methed you may find a bit simpler.

1.1.1.1 2001 = Router 1
1.1.1.1 2002 = Router 2
1.1.1.1 2003 = Router 3

CaveLab#1.1.1.1 2003
Open

The above example sends you to r3.

If all is correct R1s routing table should look like this:

R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.255.0/30 is directly connected, Serial0
D 172.16.255.4/30 [90/2195456] via 172.16.1.2, 00:14:01, Ethernet0
C 172.16.1.0/24 is directly connected, Ethernet0
D 172.16.2.0/24 [90/307200] via 172.16.1.2, 00:14:01, Ethernet0