EMP & Lightning Home Surge Protection
EMP - Click Here!
Phone.com 300x250
300x250 Your Business Phone Service in the Cloud
Global Test Supply
defencebyte.com
Antiransomware
Linked Banner to your Product or Website
Meticore Weight Loss Voted #1.
Daily Excellence
Previous Thread
Next Thread
Print Thread
Rate Thread
Page 1 of 2 1 2
Joined: Dec 2005
Posts: 26
Tom Man Offline OP
Member
OP Offline
Member
Joined: Dec 2005
Posts: 26
Hey Guys,

My Allworx 6x system email server has been working perfectly for years. We use it to email VM message as they are received. For some unknow reason, it just stopped working a few days ago. Through the system admin portal > email server > modify the "send test email" now fails. I'm using gmails' smtp servier and the authenication is correct. Any ideas? Thanks!

BrandsMart USA
Current Ad
Joined: Jul 2014
Posts: 6
Member
Offline
Member
Joined: Jul 2014
Posts: 6
I just wanted to note that I'm just now seeing a similar problem that cropped up in the past week, and sounds very similar to Tom_Man's issue.

We have an Allworx 6x unit (Ver. 7.6.7.3) that has been running fine for us for over a year now. I initially configured the unit to send VM as email attachments and/or SMS notifications. We also use smtp.gmail.com:587 as our SMTP host/MTA and it has been working fine for over a year, until just recently...

Since 7/26 (or possibly earlier) the emails are not being accepted by GMail's SMTP host, and I'm seeing errors in the AllWorx log like this: "tSmtpC00: SMTP Relay: My EHLO name was rejected "

I assume that this may be due to a change on GMail's back-end, but does anyone else have any insight into the issue, or a work-around/solution? Again, I am assuming that this is a SMTP/MTA issue on the google side, but if anyone has any suggestions as to the underlying problem or how it can be resolved from the AllWorx end, I'd greatly appreciate any assistance.

Joined: Jun 2006
Posts: 1,624
Member
*****
Offline
Member
*****
Joined: Jun 2006
Posts: 1,624
From Google for a recent report of the same/similar issue:

If you tried configuring your SMTP server on port 465 (with SSL) and port 587 (with TLS), but are still having trouble sending mail, try configuring your SMTP to use port 25 (with SSL).

https://productforums.google.com/forum/#!topic/gmail/Tv0WGHSleZY


"I'm the one that has to die when it's time for me to die, so let me live my life, the way I want to."
-- Jimi Hendrix

Joined: Apr 2001
Posts: 1,389
Member
Offline
Member
Joined: Apr 2001
Posts: 1,389
More and More smtp host are blocking their use if it detects that the outgoing mail is using it as a "relay". I suspect in your allworx setup, you are using smtp.gmail.com as the outgoing host, however the email header may say its is coming from [email protected], totally unrelated to the gmail account authenticating for smtp. Gmail may have updated their policy to help target spam.

Then again, the denial may be coming from xyz.com, as smpt.gmail.com may not have authority to send mail for xyz.com. Please research SPF.

Joined: Jul 2014
Posts: 6
Member
Offline
Member
Joined: Jul 2014
Posts: 6
Keighlar,

Thanks for suggesting the alternate SSL/TLSSSL ports and providing the link. However, I've tried the alternate settings, and the system is still failing to relay the emails to the GMail SMTP server. The error message is similar to this: "tSmtpC01: SMTP Relay: My EHLO name was rejected"

One possible issue that I'd like to inquire about, is the Allworx's domain.
Current settings are: (Home > Network > Configuration > Domain Name [DNS]...)

Host Name lily
Domain Name (DNS) allworx.com

which means the device should presumably identify itself with the FQDN of lily.allworx.com. Our public DNS records have a valid A record for the device as lily.MYREALDOMAIN.COM. The installer indicated that the Allworx needed to retain the allworx.com domain for some reason that he never fully explained. We host our email externally with Google, and don't ever plan on using the AllWorx for any _real_ email. I haven't found any other recent reports of AllWorx boxes suddenly no-longer relaying email to one of the largest email providers in the world, but I have to assume that something changed behind the scenes to cause this otherwise stable subsystem to suddenly start failing.

Anyone else have any input, questions, or suggestions on how to continue troubleshooting this?

Joined: Jul 2014
Posts: 6
Member
Offline
Member
Joined: Jul 2014
Posts: 6
Rusty,

Thanks for bringing up the issues with relays and SPF, however I have had this setup successfully, as per GMails instructions on using the full GMail-hosted email address and password for over a year on this PBX, and SPF has been setup before, and is unchanged. I am aware of the setting the Email Sender and Username to the full, valid email address, the non-standard ports and all the other GMail-specific issues for SMTP and IMAP. I utilize GMail's SMTP email relaying for multiple devices at client sites, and have run into no major problems until this.

Seeing as someone else suddenly reported the same issue this week, I have to assume that GMail has tightened down on SMTP relaying, but I can find no reports of recent changes or large numbers of problems suddenly reporting that smtp.gmail.com is refusing to relay emails this week.

Any other reports of other Allworx users with the default allworx.com domain still set on the unit, suddenly no longer being able to relay via GMail?

Joined: Jul 2014
Posts: 6
Member
Offline
Member
Joined: Jul 2014
Posts: 6
OK, I did some additional digging and found that others _did_ report similar issues starting last week, ( https://productforums.google.com/forum/#!topicsearch/smtp.gmail.com$20EHLO$20server/gmail/MUdRHbZYTDk ) and it appears that GMail has changed part of their SSL/TLS authenticatio & handshake, thus breaking this functionality. I will discuss this with our AllWorx installer and see if he can get us an ETA on AllWorx producing a fix/patch/update. Thanks for everyone's advice, and I'll try to put up a post-mortem on this once I've gotten it fixed.

Joined: Mar 2001
Posts: 3,268
Moderator-Allworx, Nisuko-Tie, Vodavi
Offline
Moderator-Allworx, Nisuko-Tie, Vodavi
Joined: Mar 2001
Posts: 3,268
"I'll try to put up a post-mortem on this once I've gotten it fixed."

Thanks, Wombat. Keep us informed.

Joined: Jul 2014
Posts: 6
Member
Offline
Member
Joined: Jul 2014
Posts: 6
After mucking about with the email server settings last night, the Allworx started auto-magically sending the backlog of queue'd messages through GMail's SMTP relay.

Use External SMTP Server enabled
SMTP Server Address smtp.gmail.com
SMTP Server Port 25
SMTP Display Name AllWorx Admin
SMTP Sender's Email Address [email protected]
SMTP Server requires authentication yes
SMTP Server User Name [email protected]
SMTP Server secure connection SSL

This morning, our Allworx vendor signed into the unit remotely and looked over my settings, not knowing that I'd 'fixed' the problem. He changed the SMTP port to 465 and the system continues to work normally. I don't know if GMail resolved the issue on their end last night, or if I somehow missed a setting when troubleshooting this over the past few days, but it's working now, and I'm loath to risk upsetting it again.

Best of luck to anyone else who's having this issue, I'll post more info if it becomes available.

Joined: Dec 2009
Posts: 90
Member
Offline
Member
Joined: Dec 2009
Posts: 90
I myself have been fighting this for two weeks. All started from a password change. Got the password back and have had problems since. Problems also continued with creating new accounts. I even went to Yahoo briefly although it stopped working after a few days.

I've been on the phone with Google several times and Allworx several times. Starting yesterday though I have noticed that one of my accounts has started to work. On ours and another though I tried this setting that was recommended by google and so far it has been working. It is a restricted SMTP address they gave me to try.

Use External SMTP Server enabled
SMTP Server Address aspmx.l.google.com
SMTP Server Port 25
SMTP Sender's Email Address [email protected]
SMTP Server requires authentication NO

SMTP Server secure connection NONE


I hope they do rectify this issue as it has been great being able to verify the sent messages in the GMAIL account periodically.

Page 1 of 2 1 2

Moderated by  JWRacedog 

Link Copied to Clipboard
Advertising Sponsor
Popular Topics (Views)
Forum Statistics
Forums94
Topics94,457
Posts640,016
Members49,481
Most Online5,661
May 23rd, 2018
Today's Birthdays
docjim, eddycurrent, FC de Argentina, matts520, NetworkKing, Randy from RACE, Zyeith
Newest Members
Goracing57, Michael Duffy, Jim22, hummerdave, Rusenga D
49,481 Registered Users
Get Tech Support Now! Click the banner below
Get Tech Support Now!
Top Posters (30 Days)
dexman 33
Ruben 9
OBT 5
NordVPN
Advertising Sponsor Spot 2
EMP Shield for Commercial - Home & Vehicle
Use Coupon code SAVE - Click Here!
Who's Online Now
18 members (jeffmoss26, dexman, EV607797, justbill, Carl Navarro, metelcom, sundance, BrianS, mbhydro, hitechcomm, OBT, Silversam, pvj, Professor Shadow, hbiss, Keyset6, JBean3329, 1 invisible), 156 guests, and 144 robots.
Key: Admin, Global Mod, Mod
Contact Us | Telephone System Tech Support | Terms of Service

Sundance Communications is not affiliated with any of the above manufacturers.
©Copyright Sundance Communications 1998-2021
Trusted Partners
landing page builder Antiransomware 300x250 Your Business Phone Service in the Cloud