Business Phone Systems

Previous Thread
Next Thread
Print Thread
Rate Thread
#613948 11/06/17 10:03 PM
Joined: Nov 2005
Posts: 645
Member
OP Offline
Member
Joined: Nov 2005
Posts: 645
Hi all -

I have an issue with a 2404 DECT Ct where it stopped working. The battery is fully charged but still says acquiring link. It was originally installed in 2011. They are not convinced it is the battery. Any other ideas?

Atcom VoIP Demo
VoIP Demo
Joined: Jun 2005
Posts: 2,654
Likes: 4
Member
Offline
Member
Joined: Jun 2005
Posts: 2,654
Likes: 4
Have you already reset the base? I have had to do that once in a while.

Is it tandem with a working phone? Maybe the phone connection got disconnected. I would plug in a phone just to make sure.

The user guide has instructions on how to register the handset to the base. Maybe you can try to register to the base again.






Joined: Nov 2005
Posts: 645
Member
OP Offline
Member
Joined: Nov 2005
Posts: 645
It is a stand alone extension. If they plug another phone into where this one should be that phone works OK. I will look into re-registering the handset to the base.


Moderated by  Carlos#1, phonemeister 

Link Copied to Clipboard
Forum Statistics
Forums84
Topics93,832
Posts636,785
Members49,649
Most Online5,661
May 23rd, 2018
Popular Topics(Views)
Today's Birthdays
bravesfan, cjvio, Cory S., Jack Scott, l.landeche, TexasD
Newest Members
devben, bubblegum, Carl Arnold, Marjan Shaw, KoolBreeze
49,648 Registered Users
Top Posters(30 Days)
ramo 13
pvj 11
Toner 9
Who's Online Now
0 members (), 25 guests, and 25 robots.
Key: Admin, Global Mod, Mod
Contact Us | Sponsored by Atcom: Business Phone Systems | Terms of Service

Sundance Communications is not affiliated with any of the above manufacturers.
©Copyright Sundance Communications 1998-2023
Powered by UBB.threads™ PHP Forum Software 7.7.5