EMP & Lightning Home Surge Protection
EMP - Click Here!
Phone.com 300x250
300x250 Your Business Phone Service in the Cloud
Global Test Supply
defencebyte.com
Antiransomware
vpnproxymaster
Linked Banner to your Product or Website
Turn your commission checks on autopilot with 50% RECURRING COMMISSIONS!
Flexibits
Meticore Weight Loss Voted #1.
Get leads. Get sales. Get growing with Getresponse
Get leads. Get sales. Get growing. [2]
Previous Thread
Next Thread
Print Thread
Rate Thread
#248131 11/09/11 03:09 PM
Joined: Nov 2011
Posts: 3
grey949 Offline OP
Member
OP Offline
Member
Joined: Nov 2011
Posts: 3
I'm having issues with our IP phones (DSX VOIP 34B). I have everything to default settings, but audio is only working one way. The IP phone can not hear the other side, but the other side can hear the IP Phone.

However, if I use the same settings/login/ext with X-Lite (from my laptop), it works perfectly. Both my laptop and the IP Phone are on the same switch, so I don't think it's a networking issue. For now this is all LAN based.

The DSX system is running v3.34. The system has a static IP reserved from our DHCP server. For the SIP port, I'm using the default 5060. For the RTP Range Start I'm using 1024 (the RTP Range End box is greyed out and shows 1215, which seems odd).

A few more notes. When I leave the phone RTP port at default (which is 3462), it will do the one way audio (see above), but if I set it to 1024, there is no audio (yet it will ring and dial out). I ran wireshark while running X-Lite and can see it's using RTP port 1080. If I set the IP Phone to use 1080 it will behave the same as using 3462, again only one way audio. (Again note that X-Lite works perfectly with two way audio).

I've tried a factory reset of the phone, didn't change anything. Phone HW Stats:
Hardware Ver 9.1.3.5
Firmware Ver 1.0.7.2

Any ideas? help

Global Test Supply 728x90
Joined: Nov 2011
Posts: 3
grey949 Offline OP
Member
OP Offline
Member
Joined: Nov 2011
Posts: 3
Interesting update. In the DSX System, under (1801), I changed the RTP Range Start to 1080 (RTP Range End is greyed out to 1271).

I still only get one way audio, but now it's the other way around! Meaning, the IP Phone can hear the other line but not vice versa, which is the opposite scenario I was seeing earlier.

I should also note that this is a new setup, meaning they've never worked for us. I've also tried different IP Phones to make sure it wasn't a HW issue.

Another note is that when I use wireshark against the IP Phone (using a Hub this time), the source RTP port is 1136. Very strange....

Joined: Nov 2011
Posts: 3
grey949 Offline OP
Member
OP Offline
Member
Joined: Nov 2011
Posts: 3
Solved it!

Spent a couple hours hammering away with wireshark/zenmap.

So when I set the RTP port range on the DSX from 1024-1087 audio works one way (note: it would only use port 1080). Setting it to 1080-1271 would allow audio one way but in the different direciont (note: it would only use port 1136).

1136 seemed to be the trick.

I set the RTP range to 1135-1199 and it worked.

Doesn't make any sense at all especially since the softphone worked fine with any range and it's on the same switch.

The real challenge will be getting these to work off site.


Moderated by  ttech 

Link Copied to Clipboard
Advertising Sponsor
Popular Topics (Views)
Forum Statistics
Forums94
Topics94,431
Posts639,815
Members49,470
Most Online5,661
May 23rd, 2018
Today's Birthdays
Extreme, medhat eme, Telephonyman, TonyW
Newest Members
BezLovesITAD, AndreLS, JimLafleur, EssKayKay, xmestedex
49,470 Registered Users
Get Tech Support Now! Click the banner below
Get Tech Support Now!
Top Posters (30 Days)
dexman 12
hbiss 4
www.aweber.com
landing page builder
NordVPN
Advertising Sponsor Spot 2
EMP Shield for Commercial - Home & Vehicle
Use Coupon code SAVE - Click Here!
Who's Online Now
16 members (RATHER BE FISHING, justbill, gelehu, Yoda, JBean3329, dexman, metelcom, Curlycord, BobRobert, Skunky, NateBates, EV607797, nortelvoip, Mercenary Roadie, Daniel, jeffmoss26), 198 guests, and 91 robots.
Key: Admin, Global Mod, Mod
Contact Us | Telephone System Tech Support | Terms of Service

Sundance Communications is not affiliated with any of the above manufacturers.
©Copyright Sundance Communications 1998-2021
Trusted Partners
landing page builder Antiransomware 300x250 Your Business Phone Service in the Cloud